Issues connecting to cloud storage
Incident Report for digi.me developers
Resolved
This incident has now been resolved. We'll continue to monitor our systems for any further occurences.
Posted Dec 14, 2020 - 16:52 UTC
Investigating
We are investigating an issue that is occasionally preventing people from connecting to their cloud storage through digi.me. If you run into the problem, please feel free to reach out to our support team so that they can alert you when it has been resolved.

We'll provide further updates here as information becomes available.
Posted Dec 14, 2020 - 09:37 UTC
This incident affected: Personal Cloud Storage (Dropbox, Google Drive, OneDrive).